Unlimited Powerpoint templates, graphics, videos & courses! Unlimited asset downloads! From $16.50/m
Advertisement
  1. Business
  2. Microsoft Excel
Business

Как Использовать Выражение ЕСЛИ в Excel

by
Difficulty:IntermediateLength:MediumLanguages:
This post is part of a series called How to Make and Use Excel Formulas (Beginner Bootcamp).
How to Concatenate in Excel to Combine Text Strings
How to Work With Date and Time Formulas in Excel

Russian (Pусский) translation by Andrey Rybin (you can also view the original English article)

Excel - один из самых мощных и простых в использовании инструментов для работы с данными. Электронные таблицы - это инструмент для организации, расчета, и просмотра ваших данных.

Что происходит, когда нам нужно создать процедуры выборадля нашей таблицы? В этом случае на помощь приходит выражение ЕСЛИ.

Представьте, что у нас есть таблица со списком оценок, по нашим школьным курсам. Я хочу напомнить себе, сдал я или провалил экзамен, отобразив это текстом "passing" (сдал) или "failing" (провалил). Я могу написать формулу с выражением ЕСЛИ, которая будет смотреть на окончательную оценку, и в зависимости от количества балов выдавать текст "passing" или "failing".

Excel IF statement example
Это простой вариант функции ЕСЛИ которая оценивает количество балов в столбце B и напоминает мне, на основании набранных балов, сдал я или провалил курс.

Формула ЕСЛИ в Excel делает ваши электронные таблицы намного "умнее". Мы можем создать для ячейки разные варианты, которые будут отображаться в зависимости от условий. Формула ЕСЛИ позволяет нам добавить логические операции в нашу электронную таблицу. В этом уроке, я покажу вам, как ее использовать.

Как Использовать Оператор ЕСЛИ в Excel (ВидеоУрок)

В этом видеоуроке, я покажу вам как я использую оператор ЕСЛИ в Excel, что бы сделать электронную таблицу "умнее". Посмотрите это видео, что бы проследить за процессом создания условных выражений с ЕСЛИ, и затем посмотрите напечатанные ниже инструкции урока.

Прежде, чем мы приступим к нашему уроку, я рекомендую вам загрузить бесплатную книгу Excel с примерами, которую я создал специально для этого урока.

Как Работает Оператор ЕСЛИ в Excel?

Для успешного использования оператора ЕСЛИ надо задать три аргумента:

  1. Что Проверять - Собственно, что будет проверяться на условие ЕСЛИ? Мы можем, например, проверить, равняется ли значение в ячейке определенному числу, или содержит ли она определенный текст.
  2. Что Показывать Если утверждение Истинно - Если условие которое мы проверяем выполняется то, что мы должны отобразить в ячейке?
  3. Что Показывать Если утверждение Ложно - Если выражение не содержит, того чего мы ищем, что нужно отобразить в таком случае?

Оператор Excel ЕСЛИ начинается с =ЕСЛИ(. В официальной документации к Excel, показана структура оператора ЕСЛИ:

=ЕСЛИ(логическое выражение;[значение если истинна];[значение если ложь])

На мой взгляд на простом русском правило использования оператора ЕСЛИ можно записать так:

=ЕСЛИ(что нужно проверять; что показывать если правда; что показывать если ложь)

Достаточно просто? Если кажется, что пока плохо понятно, давайте перейдем к самому первому примеру, в котором показано, как использовать оператор ЕСЛИ, и посмотрим как он работает.

Создание Вашей Первой ЕСЛИ - функции

Для этого примера, используйте Лист с названием "Check for Blank", из Книги с Примерами.

Мы начнем с простейшего примера использования функции ЕСЛИ. В этом примере, мы всего лишь проверим, является ли ячейка пустой, и напечатаем сообщение.

Давайте допустим, что мы создали список, для заполнения сотрудниками, по поводу праздничной вечеринки в офисе. Нам необходимо написать формулу, чтобы определить, кому напомнить, написать для себя блюдо. Изначально, наши данные представляют из себя список имен и подписей, что каждый должен принести:

Before Example of If Statement

Хотя я и так вижу, что некоторые ячейки пусты, давайте напишем ЕСЛИ формулу, что бы напечатать в стоблце D, кому мы должны напомнить принести еду. Моя формула ЕСЛИ должна проверить является ли ячейка в столбце С пустой, и напечатать напоминание, тому кто еще не подписался.

Вот, что я написал:

=ЕСЛИ(C2="";"напомнить им!";"они уже оставили запись")

Давайте разделим эту формулу на четыре части:

  1. Каждая формула ЕСЛИ начинается с =ЕСЛИ(
  2. Дальше, я собираюсь проверить, являются  ли значения в столбце С пустыми, поэтому я написал С2 ="",  написанные рядом знаки кавычки, без текста между ними, позволяют проверить, является ли ячейка пустой. Точка с запятой в конце, позволяют нам перейти к следующей части формулы.
  3. Следующая часть формулы - это то, что мы будем показывать каждый раз, когда выражение окажется истинным. Так как мы проверяем является ли ячейка пустой, мы собираемся вывести надпись"напомнить им", если она пустая.
  4. Если С2 содержит какой-то текст, мы будет писать, что этот человек уже оставил запись.

И наконец, вот результаты, после того, как мы записали формулу и применили ее к другим ячейкам ниже:

IF Statement walkthrough
После записи формулы ЕСЛИ и применения ее к нижним ячейкам, каждая ячейка в столбце D выдает правильную величину.

Отлично! Обратите внимание, что рядом с пустой ячейкой в столбце C, Excel печатает, что мы должны напомнить этому человеку оставить запись. Теперь мы можем, используя колонку D, отобрать кого нужно, и отправить им напоминание по почте.

Это простой пример, того, как с помощью функции ЕСЛИ в Excel, мы можем добавить логики в наши электронные таблицы. Давайте рассмотрим другие примеры.

Проверка Значений

Для этой части урока используйте Лист Test Values из скачанного файла с примерами.

Итак, мы использовали оператор ЕСЛИ, чтобы проверить, содержит ли ячейка текст. Теперь, давайте используем оператор ЕСЛИ, что бы проверить численное значение.

В первом примере, мы проверяли, содержит ли ячейка в столбце С элемент текста. Заметьте, что мы использовали знак равно, что бы проверить, является ли содержание ячейки пустым. Мы можем использовать любые математические операторы, чтобы проверить значение величин, такие как:

  • = - чтобы проверить равенство содержимого ячейки определенной величине.
  • <> - чтобы проверить, что содержимое ячейки неРавно определенной величине
  • > - чтобы проверить, что содержимое ячейки больше величины в формуле
  • < - чтобы проверить, что содержимое ячейки меньше величины в формуле
  • >= - чтобы проверить, что содержимое ячейки больше или равно величине в формуле
  • <= - чтобы проверить, что содержимое ячейки меньше или равно величине в формуле

Предположим, что нам необходимо провести инвентаризацию склада. Мы продаем наш продукт партиями по 10, таким образом каждая партия, которую мы проверяем должна иметь именно это количество. Давайте напишем формулу, которая позволит это проверить.

В данных ниже, я выписал запас продукции на складе. Мне нужно написать формулу в столбце Е, что бы проверить и убедиться, что для каждого продукта, количество соответствует 10. Если это не так, то мы должны напечатать предупреждающее сообщение.

В столбце Е, я написал формулу:

=ЕСЛИ(D4<>10;"необходимо обратить внимание";"")

Давайте разберем ее по частям:

  • Во-первых, я использую оператор <>, что бы проверить что значение в ячейке D4 не равно 10, что указывает на проблему.
  • Далее, я добавил сообщение в кавычках "необходимо обратить внимание", которая будет появляться каждый раз, если в соседней ячейке значение не равно 10.
  • И, наконец, после точки с запятой я добавил пару кавычек без содержимого между ними, поэтому если число равно 10, формула ничего не напечатает.
If Statement Value Test
Результат работы функции.

На скриншоте выше, вы можете увидеть, как я использовал формулу, что бы добавить предупреждающее сообщение для для складских позиций. Если значение в столбце D не равно 10, Excel напечатает сообщение "необходимо обратить внимание" в столбце Е.

Как Использовать ЕСЛИОШИБКА

Есть особый оператор для функции ЕСЛИ в Excel, что бы работать с ошибками в ваших формулах. Формула ЕСЛИОШИБКА, подобна оператору ЕСЛИ, но она позволяет отследить широкий набор всевозможных ошибок, и заменить их более полезными сообщениями.

Вот набор ошибок, которые может отследить функция ЕСЛИОШИБКА, согласно документации Microsoft:

  • #N/A
  • #VALUE!
  • #REF!
  • #DIV/0!
  • #NUM!
  • #NAME?
  • #NULL!

Чтобы использовать ЕСЛИОШИБКА, поместите существующую формулу в скобки функции ЕСЛИОШИБКА, и предложите величину, которую функция будет возвращать.

Вот как я собираюсь использовать ЕСЛИОШИБКА:

=ЕСЛИОШИБКА([ваша формула];[чем заменить сообщение об ошибке])

Давайте рассмотрим очень подходящий случай для использования ЕСЛИОШИБКА.

Пример функции ЕСЛИОШИБКА

Используйте лист IFERROR в Книге с примерами, для этого раздела.

Один из случаев, который может привести к ошибке при использовании формулы ВПР. Если вы используете ВПР, чтобы найти совпадения, есть шанс, что в просматриваемой вами таблице совпадений не будет. Когда такое случается, вы получаете ошибку "N/A" в своей таблице.

В электронной таблице ниже, я создал список фрилансеров работающих на меня на работе. Я сделал список компаний в которых они работают, и я хочу знать, чем каждый человек занимается. Для большинства фрилансеров у меня есть таблица справа, в которой приводятся чем они занимаются.

IFERROR Example Implementation
Эта таблица имеет некоторые ошибки, N/A, потому что в ней есть несколько отсутствующих совпадений.

Я уже написал ВПР функцию которая выдает информацию, какую работу выполняет фрилансер, в зависимости от совпадения с названием компании, которые перечислены в столбце B моей таблицы:

=ВПР(B2,$E$4:$F$6,2,ЛОЖЬ)

Но тут есть проблема: несколько компаний отсутствуют в моей справочной таблице, и поэтому у нас возникают такие ошибки - N/A. Давайте заменим их чем-то более приличным. ЕСЛИОШИБКА, которую мы собираемся использовать, имеет следующую структуру:

= ЕСЛИОШИБКА(существующая формула, чем заменить ошибку)

В моем случае, я собираюсь заменить ошибку, напоминанием связаться с моим HR менеджером, что бы проверить чем занимается этот фрилансер. Вот моя формула:

=ЕСЛИОШИБКА(ВПР(B3,$E$4:$F$6,2,ЛОЖЬ),"Contact HR")

Эта формула, может показаться сложной, но запомните: все, что мы делаем это помещаем существующую формулу ВПР, с замещающим сообщением в скобки. Мы просто окружаем нашу формулу функцией ЕСЛИОШИБКА и даем Excel величину для возвращения.

IFERROR Implemented Example
Я заменил ошибку N/A на более полезный и читаемый текст"Contact HR" (Связаться с HR).

Короче говоря, ЕСЛИОШИБКА является особым вариантом функции ЕСЛИ, которую корпорация Майкрософт разработала для нашего удобства. Она автоматически вылавливает ошибки в формулах и выводит вместо этого заданную нами величину (или сообщение).

Резюмируем и Продолжаем Обучение

Оператор ЕСЛИ - метод, который позволяет добавить условные выражения в ваши электронные таблицы. В этом уроке вы узнали как использовать формулу и посмотрели некоторые возможные варианты ее использования в таблицах.

Не важно как давно я использую Excel, я все время нахожу что-то чему еще можно научиться. Если вы хотите продолжить обучение и узнать больше о том, как использовать электронные таблицы, я предлагаю вам еще несколько уроков:

  • Официальная документация корпорации Майкрософт -первое к чему я прибегаю при изучении новой формулы, и их документация по оператору ЕСЛИ не исключение.
  • Если вы задумывались об использовании оператора ЕСЛИ, возможно вы относитесь уже к продвинутым пользователям Excel. Для вас дополнительным навыком может быть использование ВПР-функции, для поиска совпадений в списках.
  • Если вы хотите пойти дальше, посмотрите этот урок по вложенным функциям ЕСЛИ с Exceljet. Вместо простой функции ЕСЛИ, которая предоставляет вам два варианта на выходе, использование вложенных формул дает вам гораздо больше вариантов.

Если у вас возникнут проблемы с использованием функции ЕСЛИ в Excel, дайте мне знать об этом в комментариях. Или, если у вас есть идеи, как использовать эти формулы, которыми вы захотите поделиться с другими, делайте это так же в комментариях.

Advertisement
Advertisement
Advertisement
Advertisement
Looking for something to help kick start your next project?
Envato Market has a range of items for sale to help get you started.